Gunboards Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter · #1 ·
After getting a rather nasty and dirty m1 garand H&R, I tore her down and cleaned it spotless... The trouble is that now the saftey will not move into the "safe" position... I took the trigger housing back out and looked at it and honestly don't know how it ever did move all the way into the trigger guard.. BUT IT USED TOO before I cleaned it... No leftover parts were found..
Any help would be appreciated..

thanks,

jim
 

·
Registered
Joined
·
3,471 Posts
Try putting some grease on the areas that contact and cam the hammer back.
When the safety is applied, it has to cam the hammer back and sometimes these are just hard to engage without some grease.

Also, try pushing the hammer back and applying the safety. If it simply won't go ON, you have something mis-assembled.
 

·
Registered
Joined
·
30 Posts
Discussion Starter · #3 ·
thanks... I can get it to work with the trigger group out... I can manually pull the piece that bolt normally hits far enough to allow it to work. Is not going back far enough when it is cocked now.....

oh well thanks for the info..

Jim
 

·
Registered
Joined
·
102 Posts
Go on " You Tube" and type in M1 Garand Trigger Group and you will find a couple of short video's on how to disassemble and reassemble the trigger group. Once you have it apart you might be able to see if your safety is bent or if it might have another problem. (Caution), some M1 trigger groups go togeather pretty easy and some not so easy. The spring on the plunger can be a tough one.
Good Luck
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top